CİSCO L2 SWİTCH KURULUMU VE KOMUTLARI

 

Cisco kendine has IOS işletim sistemi ile donatılmıştır. Belli başlı komutları kullanacağız. “Enable” modu, “Configure Terminal” modu, “Interface” ve “vLan” oluşturmayı anlatacağız. Ayrıca tüm detayları nasıl görebileceğimizi “Show” komutu ile listeleyeceğiz.

Bir console kablosu ile cihazımıza bağlanıyoruz. Console kablosu genellikle bir ucu Ethernet RJ-45 diğer ucu ise RS232 kablosu olur. Paketlerde bazen çıkıyor bazen çıkmıyor.

Kablomuzu bağladığımızda Serial ayarlarını yapıyoruz. COM1 (değişken) ile Putty veya alternatif programlar kullanılabilir. Standart olarak 9600 bandını kullanır. Aslında şöyle düşünebilirsiniz bir nevi VGA kablosu takılmış gibi bir kablo bağlayıp cihazın başlangıcından tutup kapanana kadar her şeyi görebiliyoruz.

İlk bağlantımızda karşımıza bir wizard ekranı gelir. Burada no “n” yazıp enter diyoruz.

Switch üzerinde değişiklik yapabilmek için “enable” yazıp Switch# alanına giriyoruz. Buradan hemen “conf t” yazıp configuration alanına geçiyoruz. “conf t” aslında “configure terminal” in kısaltılmış halidir.

——————————————————-

Switch>enable
Switch#configure terminal

Öncelikle güvenlik için login kısımlarını ayarlamamız gerekmekte,

Switch(config)#line con 0
Switch(config-line)#password cisco (şifremiz cisco)
Switch(config-line)#login
Switch(config-line)#end

Yukarıda yapılan konfigürasyon console kablosu ile bağlandığımızda şifre sorması için uyguladık.

——————————————————-

Aşağıda ise telnet ile bağlandığımızda (güvenlik için telnetin kapalı olması taraftarıyım) vty 0 4 login olunması için gerekli konfigürasyonu yapacağız. vty nin sonundaki “4” anlamı aynı anda 4 kişinin bağlanabilceğini belirtir. isterseniz vty 0 1 olarak da ayarlayabilirsiniz.

Switch>enable
Switch#conf t
Switch(config)#line vty 0 4
Switch(config-line)#password cisco (şifremiz cisco)
Switch(config-line)#login
Switch(config-line)#end

Evet cihazımızın güvenliğini sağlamış olduk.

——————————————————-

Arkadaşlar bazen şifremizi yazıyoruz ama ekranımız açık bir şekilde bırakıp gidebiliyoruz. Bu yüzden kötü niyetli biri tarafından şifrelerimiz öğrenilebilir. Bu nedenle şifrelerimiz encrypt etmemiz gerekiyor.

Switch>enable
Switch#conf t
Switch(config)#service password-encryption

Yukarıdaki gibi şifreler encryp edildi. “show run” dediğimiz zaman şifrelerimiz aşağıdaki gibi gözükecektir.

Switch>enable
Switch#show run
line con 0
password 7 0822455D0A16 (şifre encryp edildi)
login
!
line vty 0 4
password 7 0822455D0A16 (şifre encryp edildi)
login

——————————————————-

vLan tanımı yapılması için gerekli konfigürasyonumuza geçiyoruz.

Switch>enable
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10 (vlan 10 oluşturduk)
Switch(config-vlan)#
Switch(config-vlan)#name Yonetim (vlan 10 için isim tanımladık)

——————————————————-

Farklı bir vlan daha oluşturalım

Switch>enable
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 33 (vlan 33 oluşturduk)
Switch(config-vlan)#
Switch(config-vlan)#name Yonetim (vlan 33 için isim tanımladık)

——————————————————-

Arkadaşlar vlan 10 için bir ip tanımlamamız gerekiyor. Uzaktan telnet ile bağlanmak istersek aşağıdaki gibi vlan 10 interface ine IP tanımlıyoruz..

Switch>en
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface vlan 10
%LINK-5-CHANGED: Interface Vlan10, changed state to up
Switch(config-if)#ip address 10.0.0.254 255.255.255.0
Switch(config-if)#end

Yukarıdaki gibi vlan 10 interface IP adresi tanımladık. Artık cihaza telnet ile uzaktan bağlanabilir duruma getirdik.

——————————————————-

Switch üzerinde bulunan interface lerimizi aşağıdaki gibi vlan’lara tanımlayacağız.

Switch>en
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface fastEthernet0/1
Switch(config-if)#switchport access vlan 10
Switch(config-if)#speed auto
Switch(config-if)#duplex auto
Switch(config-if)#exit
Switch(config)#interface fastEthernet0/2
Switch(config-if)#switchport access vlan 33
Switch(config-if)#speed auto
Switch(config-if)#duplex auto
Switch(config-if)#end

Bir cevap yazın