Cisco Router İlk Yapılandırma

router1

Daha önce de benzer yazılar yazmıştım aslında ama incelediğimde çok dağınık olduğunu farkettim ve sıfırdan bir router yapılandırmak istenildiğinde gerçekleştirilmesi gereken temel ayarları içeren, nasıl yapılır dökümanı hazırlamaya karar verdim.

Router’ın Adlandırılması

Konfigürasyonunu gerçekleştirmek istediğimiz router’a isim vermek için aşağıdaki adımların uygulanması gereklidir.

Sakir-Router>enable
Sakir-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Sakir-Router(config)#
Sakir-Router(config)#hostname Sakir-Router1
Konfigürasyon için domain name belirtilmesi

Sakir-Router1(config)#ip domain-name Test.com

SSH bağlantısının şifreli bir şekilde yapılması için kriptolu bir anahtar oluşturma

Sakir-Router1(config)#crypto key generate rsa

The name for the keys will be: Sakir-Router1.Test.com

Choose the size of the key modulus in the range of 360 to 2048 for your

General Purpose Keys. Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]: 2048

% Generating 2048 bit RSA keys, keys will be non-exportable…[OK]

SSH bağlantısı için bir kullanıcı oluşturma

Sakir-Router1(config)#username router_root password Passw0rd1!
Access List’lerin Oluşturulması

Sakir-Router1(config)#access-list 5 permit host 172.16.11.111
Sakir-Router1(config)#access-list 5 permit host 172.16.11.72
Sakir-Router1(config)#access-list 5 permit host 172.16.37.10
Sakir-Router1(config)#access-list 5 permit host 172.16.37.11
Konsole Bağlantısı için parola oluşturulması

Enable ya da Privileged mode router’ın konfigürasyon modu olduğuna göre bu modlar arasında geçiş yapmak için bir parola bilgisinin sorulması normal bir önlemdir. Bu nedenle, router’da user EXEC moddan privileged EXEC moda geçmek için de password bilgisinin sorulmasını sağlamak gerekir. Böylece router’ı konfigüre etmek isteyen kullanıcıların password’ü bilmesi gerekir.

Router ilk defa açıldığında NVRAM üzerinde bir konfigürasyon dosyasını yükler. Konfigürasyon dosyası yoksa da router ilk konfigürasyon moduna (setup mode) düşer. Bu aşama initial configuration olarak da adlandırılır. Initial Configuration iletişim kutusu temel konfigürasyon işlemlerinde kullanıcıya yardımcı olan menü sistemli bir sihirbazdır. Bu sihirbaz ile router konfigüre edilir. Ya da router’ın kullanıcı moduna düşülür ve konfigürasyon kullanıcı tarafından yapılır.

Sakir-Router1(config)#line console 0
Sakir-Router1(config-line)#privilege level 15
Sakir-Router1(config-line)# login local
Sakir-Router1(config-line)#password cisco
Sakir-Router1(config-line)#exec-timeout 10
Router’a Sadece Telnet, Sadece Ssh Ya Da Her İkisi İle Erişim Sağlanması İçin

Router’lar üzerinde access level olarak adlandırılan yönetim düzeyleri sayesinde router yönetimindeki belli görevler ayrı kişiler tarafından yerine getirilir. Cisco Router’ları 16 ayrı özel erişim düzeyine sahiptir. Bu düzeyler 0 ile 15 arasındadır. 15 değeri full erişim hakkını ifade eder. Bunun dışında ikincil yöneticiler için 2 ile 15 arasındaki, düzeyler monitoring yetenekleri için yapılandırılabilir

Default olarak bütün Cisco Router’ları aynı anda 5 Telnet oturumuna izin verir. Yinde default olarak bu erişimlere ya da VTY hatlarına herhangi bir password atanmamıştır.

Cisco aygıtlar üzerinde varsayım olarak yalnızca enable secret ile şifrelenen password bilgileri şifrelenir. Router üzerinde konfigüre edilen tüm password’leri şifrelemek için aşağıdaki komut kullanılır.

Router’lara erişim ayrıca aktivite timeout sürelerini ayarlayarak da kontrol edilebilir. Exec timeout komutu ile bu işlem yerine getirilir.

Sakir-Router1#conf t
Sakir-Router1(config)#line vty 0 4
Sakir-Router1(config-line)#access-class 5 in
Sakir-Router1(config-line)#privilege level 15
Sakir-Router1(config-line)#login local (no login ile telnet oturumu yapılmaması sağlanır.)
Sakir-Router1(config-line)#transport input ssh
Sakir-Router1(config-line)#line vty 5 15
Sakir-Router1(config-line)#access-class 5 in
Sakir-Router1(config-line)#login local
Sakir-Router1(config-line)#password parolayazilir
Sakir-Router1(config-line)#transport input ssh
Sakir-Router1(config)#exit
Sakir-Router1(config)#ip ssh version 2
Sakir-Router1(config)#ip ssh time-out 120
Sakir-Router1(config)#ip ssh authentication-retries 4
Sakir-Router1(config)#service password-encryption
Interface’lere Ip Tanımlaması Yapma

Sakir-Router1(config)#interface GigabitEthernet0/0
Sakir-Router1(config-if)#no shutdown
Sakir-Router1(config-if)#description Internet Connection Interface
Sakir-Router1(config-if)#ip address 212.175.x.x 255.255.255.248
Sakir-Router1(config-if)# duplex auto
Sakir-Router1(config-if)# speed auto
Sakir-Router1(config-if)#exit
Statik Route Tanımlaması

Sakir-Router1(config)#ip route 0.0.0.0 0.0.0.0 212.175.x.x
SNMP için Access List Oluşturma

Sakir-Router1(config)#access-list 11 permit host 172.16.8.55
SNMP Tanımlaması

Sakir-Router1(config)# snmp-server community Net-SNMP-Ornek!!! RO 11

NTP Server Tanımlaması

Sakir-Router1(config)#ntp server 192.168.100.23

 

Bir cevap yazın